Honda Crosstour Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
205 Posts
Discussion Starter · #1 · (Edited)
ughhh let me tell you about my CT wipers...usually i never replace them until the view is really obscured. So I said screw went to walmart, and bought the Michelin wiper blades paid about $10.00 bucks for each...did not fix my problem.

Returned the blades back at walmart and bought Rain-X Fusion. A little more expensive probably one of the best ones on the shelf.

Installed them no problem, turn on my wipers...SAME PROBLEM.



Now im just going to buy the rubber insert...at my local Honda Dealer...

http://www.bernardiparts.com/Honda-...erts-Crosstour__WIPERINSERTKIT-CROSSTOUR.aspx


Anyone else have this problem?

Note: I live in Jersey...so I deal with harsh both Winter/Summers.



Thanks
 

·
Registered
Joined
·
621 Posts
The only time I've had any problem like this is if there is residue on my windshield... bugs, sap, etc.

I would make sure the windshield is thoroughly clean first. Sometimes a good cleaning of a windshield, and a wet-nap cleaning of wiper blades, can bring everything back to life.
 

·
Registered
Joined
·
205 Posts
Discussion Starter · #3 ·
today it rained pretty hard. so my windshield is getting a good cleaning. Once it is clean, I will clean really good with windex and try the blades out again. If I still see the streaks/blur spots I will just change the inserts then.
 

·
Registered
Joined
·
23 Posts
today it rained pretty hard. so my windshield is getting a good cleaning. Once it is clean, I will clean really good with windex and try the blades out again. If I still see the streaks/blur spots I will just change the inserts then.
I would recommend doing more than just Windex to resolve the issue. Use actual windshield polish or some 000 steel wool. You will be surprised how much better everything looks.
 
1 - 6 of 6 Posts
Top