Honda Crosstour Forums banner

21 - 23 of 23 Posts

·
Registered
2014 Honda Crosstour EX-L V6 4WD
Joined
·
8 Posts
I replace the transmission fluids with Honda fluid around 50k and have done the diff fluid as well.

I'm going to email the tuning shop I've used in the past to see if K-Tuner can disable VCM since I'm going to be installing that anyway.

Is the main place that you buy S-VCM on eBay? Which seller? I also found this website: S-VCM Controller - Disable VCM / deactivate VCM and stop ECO in Honda Acura. Where is everyone buying it from nowadays?
 

·
Registered
Joined
·
12 Posts
I ordered mine online from www.svcmcontroller.com it actually shipped from Brossard, QC Canada. It installs super easy but I must have other issue as i can still detect the flutter/vibration at 40 & 70 mph. It is less but its still there.
I just saw this post and wanted to share my experience. I also added S-VCM due primarily to excessive oil consumption. I am still trying to get some more miles on it to see if there is a difference yet, but so far love the power and responsiveness without the ECO mode.

I also had the vibration/flutter at 40mph/70mph and that is an entirely different issue. There are some threads on here about that also that I posted on. Most likely it is your front axle causing the issue. I ended up buying an OEM Honda Left, Right, and Intermediate (center) “half shaft” to finally fix the problem. I also had a motor mount that needed replacing too.
 

·
Registered
Joined
·
8 Posts
I just saw this post and wanted to share my experience. I also added S-VCM due primarily to excessive oil consumption. I am still trying to get some more miles on it to see if there is a difference yet, but so far love the power and responsiveness without the ECO mode.

I also had the vibration/flutter at 40mph/70mph and that is an entirely different issue. There are some threads on here about that also that I posted on. Most likely it is your front axle causing the issue. I ended up buying an OEM Honda Left, Right, and Intermediate (center) “half shaft” to finally fix the problem. I also had a motor mount that needed replacing too.
Thank You, Ill check out my axels.
 
21 - 23 of 23 Posts
Top