Honda Crosstour Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
for some reason, randomly my nav screen/display screen will simply go black. Hitting the map button menu button, any button does nothing to bring it back. Turning the car off and back on brings it back to normal.
All functions work when dark, you simply can't see anything.

Honda couldn't get it to turn off or go black so they think I am an idiot.

Any thoughts?
Thanks
 

·
Registered
Joined
·
622 Posts
Very random or possibly after hitting bumps? Loose cabling somewhere?
 

·
Registered
Joined
·
1 Posts
Same problem

My nav screen wouldn't come on time to time. If I would turn off the car it would come back on. Now, though it is off and won't come on no matter what I do. I have really have gotten use to using the back camera.
 

·
Registered
Joined
·
236 Posts
for some reason, randomly my nav screen/display screen will simply go black. Hitting the map button menu button, any button does nothing to bring it back. Turning the car off and back on brings it back to normal.
All functions work when dark, you simply can't see anything.

Honda couldn't get it to turn off or go black so they think I am an idiot.

Any thoughts?
Thanks
I suppose you do know that when you turn on your car you are suppose to push in the big knob when you see ok on the screen and the Navi will show? If you do not push the knob when the Navi says ok, it then will go black, because it thinks you do not want the navi on. So are you saying that even though you push in the knob when it says ok, it goes black on you while navi is showing? If so then you do have a problem.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
I suppose you do know that when you turn on your car you are suppose to push in the big knob when you see ok on the screen and the Navi will show? If you do not push the knob when the Navi says ok, it then will go black, because it thinks you do not want the navi on. So are you saying that even though you push in the knob when it says ok, it goes black on you while navi is showing? If so then you do have a problem.

Yes I know to push the ok button. This is random as I said in the original post.
 

·
Registered
Joined
·
4 Posts
my nav started to cut out and the screen keeps scrolling weird patterns and once in a while it comes on normally for short periods. The back up camera seems to work but it can be intermittent. Anyone have similar issues? 2010 CT awd with Nav
 

·
Registered
Joined
·
3 Posts
my nav started to cut out and the screen keeps scrolling weird patterns and once in a while it comes on normally for short periods. The back up camera seems to work but it can be intermittent. Anyone have similar issues? 2010 CT awd with Nav
what did you end up doing? I think I need to replace the whole screen!
 

·
Registered
Joined
·
1 Posts
I have 2013 Honda Crosstour v6 4wd. Everything was perfect. I sent the vehicle to Africa. The nav screen/display the connection to the antenna failed. The antenna wasn’t found. I should take the car to the open area with no building, tree. I drove the car the to beach w no tree and building but nothing change.
 

·
Registered
Joined
·
3 Posts
my nav started to cut out and the screen keeps scrolling weird patterns and once in a while it comes on normally for short periods. The back up camera seems to work but it can be intermittent. Anyone have similar issues? 2010 CT awd with Nav
My 2010 CT with nav did the same thing exactly. It hasn’t worked for 3 months now. Honda offered to install new touch screen apple/android thing for $800!!! I saw quite a few of the original nav screens on ebay for about $100. It seems this is happening quite often.
 
1 - 13 of 13 Posts
Top