Honda Crosstour Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1 (Edited)
Well I just installed them. Pretty much the same exact thing as my 08 accord but there were many more of those darn black plugs to take off to get the bumper off. I took the bumper off to mount the ballast in the same exact place where I had mounted them in my accord. Basically once you take the bumper off the front end it pretty much the same. I will write a full review this weekend but once again Steve at Xenondepot quickly helped me when I had a quick question about the different in bulbs I had from my 08 Accord to my 10 Crosstour. Again showing why Xenondepot is the industry leader in customer service.

For those interested in my 08 accord write up with 5000k Xenondepot Xtreme Kit look here. The write up will be almost identical to this. I didn't take pics during the install of the 10 Crosstour as it is the same exact setup after the bumper is off.

http://www.driveaccord.net/forums/showthread.php?t=22469
 

·
Registered
Joined
·
4 Posts
I am starting my installation next weekend. I have researched the process and am ready.
But I have printed out Spikeitaudi's photos and text as a backup.
THANKS Spikeitaudi!!!!!
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
I am starting my installation next weekend. I have researched the process and am ready.
But I have printed out Spikeitaudi's photos and text as a backup.
THANKS Spikeitaudi!!!!!

No problem. I am going to write up the small difference tonight.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
Good job! I did the same for mine.

http://www.crosstourownersclub.com/forums/showthread.php?t=529

But 5000k one doesn't look any blue-ish to me, I will take more photos and post here

If you compared the 4300k next to a 5000k with the same ballast running it you would see the difference easy. 4300k is the most usable light spectrum. Any higher and you start losing the usablitlity. I had 5000k for 2 years in my accord. I just didn't like them as I had 4300k on 3 different cars before that. Had to swich back in the CT. :)
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6 (Edited)
Update on small differences on install from my 08 Accord:


Once you open up the hood you will see something like this:



Again pics from my 08 accord. Once you pop out all the black clips and get that black cover off you will see 2 additional black clips that need to get popped off on either side of the grill. These were NOT on the 08 Accord. You must take these 2 clips off as well to get the front end off.

The only other difference is if you are running the relay harness and have to run the ground back to the battery you have to run the wire infront of the radiator near the horn. You can use run zip ties to secure them as well.

Other then that all the rest is the same. The ballast mounting locations are the same. The ground locations are the same.

I will get some pics up soon but just been super busy at home lately.

Kudos to Steve again on a great product.
 

·
Registered
Joined
·
594 Posts
Thanks for taking the time to post up feedback on the board Alvin! As always, a pleasure working with you :)

Shameless Plug - We are now able to offer crosstour owners WeatherTech floor Mats :)
I'm interested in this shameless plug lol... I actually have been waiting for the floor liners to be available for the CT
 
1 - 9 of 9 Posts
Top