Honda Crosstour Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
205 Posts
Discussion Starter · #1 ·
i changed the interior lights with LED...but they wont turn on, I tried swapping them out with the old ones and they wont turn on? maybe it is a fuse, not sure. can someone please answer? now i have no lights in my car?
 

·
Registered
Joined
·
205 Posts
Discussion Starter · #2 ·
read the manual, tried to replaced the fuse....stil wouldn't turn on? I dont think its the fuse now, now im really lost. Please HELP
 

·
Registered
Joined
·
93 Posts
Which ones? Do you have a multimeter or a test light? Test the light contacts and/or the fuse contacts. Are you sure you have the right fuse? Did you disconnect and reconnect the battery (There are a few different MICUs that will wreak havoc on electronics if they sense a disturbance). I'm not in town or else I would look at that circuit in the manuals. In the owners manual, what else shares that circuit? If anything else is shared, is it working?
 

·
Registered
Joined
·
205 Posts
Discussion Starter · #4 ·
i opened the hood, grabbed the fuse remover, went under the steering wheel in the inside of the car. I then pulled fused 16 (interior lights, i replaced it with the extra fuse in the case no luck. I then put back the originals lights for the maps and closed my car.
 

·
Registered
Joined
·
205 Posts
Discussion Starter · #5 ·
2 dome lights and the back dome does not work
 

·
Registered
Joined
·
93 Posts
I wish I had my books... There is another fuse bank on the other side of the car... Check that one. Make sure the dome master is in the on position (simple, but who knows). How about the lights in the cargo area? There's a switch for those. Are those working? Make sure all of the switches are in the on or door position.
 

·
Registered
Joined
·
205 Posts
Discussion Starter · #7 ·
dome is switched to "ON".....where the side fuse box?
 

·
Registered
Joined
·
93 Posts
I want to say it's behind the dash molding, but DO NOT take my word for it. I am going off memory and I have worked on a couple of cars lately... I'd hate to confuse them. Check the manual; it should show one relay box in the engine compartment and three fuse boxes; one in the engine compartment, one by the driver's left foot or knee and the other by the front passenger's right foot or knee. Let me know what you find. Good luck.

Jay
 

·
Registered
Joined
·
93 Posts
Fuse # 16 (Interior Lights) is a 7.5 Amp fuse and is located in the engine compartment fuse box. Did you try that one? PM me with your phone number... I'll call ya if you wish and walk you through a few more... Namely Passengers side fuse box fuse # 6 (Interior Lights) 7.5 Amp.
 

·
Registered
Joined
·
205 Posts
Discussion Starter · #10 ·
i changed that one...under the steering wheel.....nothing. i think Im just going to bring it to the dealer and tell them to install the factory ones again and then give it another try.
 

·
Registered
Joined
·
93 Posts
Wait one... Go back and read my reply just before this one... There's two more worth checking... Maybe one or two more after that. You found the passenger fuse location, right. Let me know. I found a copy of the manual online and can walk you through if need be.
 

·
Registered
Joined
·
205 Posts
Discussion Starter · #12 ·
ill give it to monday, cause im busy tonight and tomorrow...thanks for your help though.
 

·
Registered
Joined
·
205 Posts
Discussion Starter · #13 ·
it was a fuse....i didnt have a fuse tester, i went to my buddies shop and he switched out the bad fuse and made sure everything worked....

Question, did anyone else have this question when they installed LED lights inside?

im going to take picture at half of the 4pm games...so you can see.

thanks every1
 
1 - 13 of 13 Posts
Top