Annoyances with the Crosstour - Honda Crosstour Forums
     Honda Crosstour Forums
Auto Insurance

Go Back   Honda Crosstour Forums > Honda CrossTour Forums > Crosstour General Discussion

CrossTourOwnersClub.com is the premier Honda Crosstour Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 01-02-2013, 12:47 AM   #1
WeirdG
Member
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 47
Default Annoyances with the Crosstour

I've had my CT for a week now, and I just found my first annoyance. There's a lot of snow where I live, and as I drive all the slush from the roads builds up underneath the doors.

The other day as day as I was getting out of my CT, the top of my foot brushed the bottom of the door. When that happened, some of the slush from the bottom of the door rubbed off onto my shoes and my pants. It also got under the bottom of my pants and onto my sock, making my foot wet. This happened to me about 3-4 time yesterday, before I actually remembered to open my door wider. The problem is, it's not always easy to open the door wide especially when you're in a parking lot full of cars, and you have a limited amount of space beside you.

Are there any other things I should expect?
WeirdG is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-02-2013, 06:39 AM   #2
deathwish
Member
 
Join Date: Dec 2012
Location: Massachusetts
Posts: 79
Default

Have you put on the splash guards? Having had mine only a week as well, and having driven in a small storm, with the accessory guards in place all my snow build-up seemed to be in the wheel well.
__________________
  • 2012 Crosstour EXL 4wd 3.5L V6 Polished Metal with Black Leather
  • 2004 Accord EXL 2.4L I4 Blue with Gray Leather, (140k since new, going strong)
  • Also maintain MIL's 2006 CRV EX 4WD Silver on Black
  • Prior ride, 1990 Prelude Si-ALB, Red/Black, (really miss that one)
deathwish is offline   Reply With Quote
Old 01-02-2013, 08:25 AM   #3
WeirdG
Member
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 47
Default

Quote:
Originally Posted by deathwish View Post
Have you put on the splash guards? Having had mine only a week as well, and having driven in a small storm, with the accessory guards in place all my snow build-up seemed to be in the wheel well.
Yup. Where I live, all new cars are sold with splash guards.
WeirdG is offline   Reply With Quote
Old 01-02-2013, 02:34 PM   #4
L8Apex
Senior Member
 
L8Apex's Avatar
 
Join Date: Nov 2012
Location: St. Charles, IL
Posts: 258
Default

Splash guards for $68 before shipping.

http://www.rchondaparts.com/oem-part.../08p00-tp6-100
L8Apex is online now   Reply With Quote
Old 01-02-2013, 10:17 PM   #5
gnwelch
Member
 
Join Date: Nov 2011
Location: Houston, TX
Posts: 34
Default

One small annoyance that I have found is that there does not appear to be a way to turn all of the ceiling lights on like there is in most cars I've ever been in. The overhead switch in the cabin only sets the lights to come on when the doors open or to off.
gnwelch is offline   Reply With Quote
Old 01-02-2013, 10:36 PM   #6
Dimples129
Junior Member
 
Join Date: Dec 2012
Posts: 14
Default

Quote:
Originally Posted by gnwelch View Post
One small annoyance that I have found is that there does not appear to be a way to turn all of the ceiling lights on like there is in most cars I've ever been in. The overhead switch in the cabin only sets the lights to come on when the doors open or to off.
I was looking for the switch to turn on the lights too...no luck
Dimples129 is offline   Reply With Quote
Old 01-02-2013, 11:10 PM   #7
WeirdG
Member
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 47
Default

I don't know if my subwoofer is working. I set it to +6 and then -6, but don't notice any difference in sound. Still testing it, but I'm pretty sure it's not working.
WeirdG is offline   Reply With Quote
Old 01-02-2013, 11:56 PM   #8
WeirdG
Member
 
Join Date: Dec 2012
Location: Edmonton, AB
Posts: 47
Default

Was just playing around with the stereo, and it seems the front speakers are too powerful. When I set the fader to +5 in the rear, I can hear the rear speakers and the sub and the front speakers aren't as overpowering. Is there anyway to increase the power to the rear speakers and the sub?

For now I'm going to set the fader to r5-r7 for a while and see if the rear speakers just need to be burned in. I've run into that a few times with home theatre speakers, so I'm hoping that's all it is.

Last edited by WeirdG; 01-03-2013 at 12:55 AM.
WeirdG is offline   Reply With Quote
Old 01-03-2013, 05:28 AM   #9
mddaddy
Junior Member
 
Join Date: Dec 2012
Posts: 6
Default i-MID fault 2013 Crosstour EX-L (and Accord)

I bought a 2013 EX-L 4 cylinder three days ago, on Dec 31, 2012, and returned it yesterday. The dealership, McDavid Honda Frisco, was kind enough to refund the entire purchase and return my trade. I only have praise for McDavid Honda, from our sales rep Lexx to the General Manager. Thank you.
I am a 2010 Crosstour owner, albeit for only 2-3 months. I bought the 2010 used, it is still in warranty with only 24,000 miles, and in two months has given me more problems than my 2000 Civic did in 8 years of ownership. I love the car's design, but it is a drivability nightmare. But that is another story.
On Monday, we took delivery of the 2013, and at the time of delivery, our sales rep noticed that some i-MID commands failed, all in the Vehicle Settings category. Door lock/unlock, forward collision warning, those sorts of things, all returned "unable to complete".
Since we had a long day at the dealership, they were crazy busy, and the weather was cold and wet, we took the car home and agreed to revisit the problem on Jan 2.
We returned to the dealer Jan 2, and after spending several hours with the car, the service writer called to tell us that the i-MID problem we were experiencing was a known issue with the new Accord, though Honda had not told the dealer about it. The i-MID software vendor, Alpine, would release a software fix in 6 to 8 weeks. Since my woes with the 2010 were still recent and painful, and after some discussion with the dealership sales manager and GM, I decided this was my last shot at Honda, and returned the car. The dealership negated the deal, and returned our trade. Again, McDavid dealerships, thank you.
I also noticed a couple of fit and finish nits - damage to the rear spoiler painted over at the factory, some carpet padding exposed where the belts pushed through the carpet. Factory should have caught these, IMHO.
You make your own decisions about Honda quality, but I have made mine. No more Honda for me; Honda corporate apparently doesn't care about customers (look up 2010 Crosstour "shutter" and "vibration" posts in this forum), and no longer builds quality cars. Good luck out there - buyer beware.
mddaddy is offline   Reply With Quote
Old 01-03-2013, 08:10 AM   #10
Cadillac Bob
Member
 
Cadillac Bob's Avatar
 
Join Date: Aug 2012
Location: Bradenton, FL
Posts: 41
Default

Quote:
Originally Posted by WeirdG View Post
Was just playing around with the stereo, and it seems the front speakers are too powerful. When I set the fader to +5 in the rear, I can hear the rear speakers and the sub and the front speakers aren't as overpowering. Is there anyway to increase the power to the rear speakers and the sub?

For now I'm going to set the fader to r5-r7 for a while and see if the rear speakers just need to be burned in. I've run into that a few times with home theatre speakers, so I'm hoping that's all it is.
The rear speakers are really very underwhelming, and they are only small mid drivers with no tweeter in them. They are basically good for little more than rear fill.
__________________
2012 Crosstour EXL, Typhoon CAI, Flowmaster 40 mufflers, 2' suspension drop, Body color 20' Cruiser Alloy wheels, Body color grille, MB Quart Components, Fosgate Sixty.3 processor, Ipad mini, HiFonics Zeus Zxi 5 channel amp, JL Audio 13.5 sub

All my other goofy car projects...
http://www.cardomain.com/id/cadillac%20bob/
Cadillac Bob is offline   Reply With Quote
Old 01-04-2013, 04:00 AM   #11
SoonerMock
Junior Member
 
Join Date: Oct 2012
Posts: 17
Default

mddaddy:
Was the 2010 you owned a green one?

I bought mine from David McDavid a few months ago as well, and I think I may have almost purchased yours!
SoonerMock is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 11:04 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.