Firmware Upgrade for iPhone Interface? - Honda Crosstour Forums
     Honda Crosstour Forums
Auto Insurance

Go Back   Honda Crosstour Forums > Honda CrossTour Forums > Crosstour General Discussion

CrossTourOwnersClub.com is the premier Honda Crosstour Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
Old 05-11-2012, 01:54 PM   #1
Xaque
Senior Member
 
Join Date: Sep 2010
Location: Western MA
Posts: 621
Default Firmware Upgrade for iPhone Interface?

So, I occasionally listen to the Pandora app through my iphone through the car...

But in order to make it work (plugged into the iPhone dock-connector/usb) I have to:

1) Make sure the pandora app is closed on my phone.
2) Plug phone in
3) Go to AUX/Iphone and begin playing all songs. (1500 or so)
4) Turn on Pandora app
5) Not touch anything.

If I rate a song up or down, or skip a song or anything, the car radio freaks out and says "Unsupported Device". I then have to unplug the phone and start over.

So, my question is: Does their exist, or is there any plan to have, a firmware upgrade for the Crosstour radio so it will play nice with 3rd party music apps on the phone?

*I understand I can plug in just the aux mini audio cable, but I would much rather plug in the dock connector so it will charge the phone as well, and I wont have to constantly switch cables over when I do decide to listen to the music stored on my phone.
Xaque is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-11-2012, 03:27 PM   #2
combscoach
Senior Member
 
combscoach's Avatar
 
Join Date: Nov 2011
Location: Denton, TX
Posts: 180
Default

That's interesting. I'm gonna try it.
__________________
Live your Life with No Regrets!
combscoach is offline   Reply With Quote
Old 05-11-2012, 07:32 PM   #3
Xaque
Senior Member
 
Join Date: Sep 2010
Location: Western MA
Posts: 621
Default

It works, but it's real finicky. I'm basically "tricking" the car into thinking I'm still playing the ipod portion of my phone... so anything that alerts the car to the contrary cuts the music and produces an error message.
Xaque is offline   Reply With Quote
Old 05-12-2012, 12:32 AM   #4
FamilyGuy
Senior Member
 
FamilyGuy's Avatar
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 123
Default

Interesting, I have the iphone4 (not 4s) and the 2010 CT. I listen to Pandora all the time in the car and it behaves very nicely. I can either start playing Pandora before I connect the cable or I can connect and go from playing my music to the pandora app with no issues. It even pauses and let's me take a call and then resumes again nicely afterwards. I can rate songs, skip, etc. without issue.
I have annoying issues with another streaming app, but not Pandora.
I'm beginning to think that this is more about the phone and the running apps and available memory, etc, than it is about the Honda.
__________________
2010 Honda Accord Crosstour EX-L 4WD
White Diamond Pearl / Ivory Leather
FamilyGuy is offline   Reply With Quote
Old 05-12-2012, 08:28 AM   #5
Xaque
Senior Member
 
Join Date: Sep 2010
Location: Western MA
Posts: 621
Default

Quote:
Originally Posted by FamilyGuy View Post
Interesting, I have the iphone4 (not 4s) and the 2010 CT. I listen to Pandora all the time in the car and it behaves very nicely. I can either start playing Pandora before I connect the cable or I can connect and go from playing my music to the pandora app with no issues. It even pauses and let's me take a call and then resumes again nicely afterwards. I can rate songs, skip, etc. without issue.
I have annoying issues with another streaming app, but not Pandora.
I'm beginning to think that this is more about the phone and the running apps and available memory, etc, than it is about the Honda.
Very interesting... I also have the 4...

I wonder what is going on here.
Xaque is offline   Reply With Quote
Old 06-04-2012, 10:50 PM   #6
Montauk17
Member
 
Montauk17's Avatar
 
Join Date: Dec 2010
Location: Huntingtown, MD.
Posts: 73
Default

Has anyone determined whether or not avsoftware update is available for streaming music from Pandora or MOG?

My son just bought a VW Golf TDI w/Navigation. The VW allows streaming of music via Bluetooth. A very nice feature. I wish the Crosstour could do that. But most of all I wish the Crosstourncould stream from apps without throwing the unsupported device error.
Montauk17 is offline   Reply With Quote
Old 06-05-2012, 08:52 AM   #7
Xaque
Senior Member
 
Join Date: Sep 2010
Location: Western MA
Posts: 621
Default

Quote:
Originally Posted by Montauk17 View Post
Has anyone determined whether or not avsoftware update is available for streaming music from Pandora or MOG?

My son just bought a VW Golf TDI w/Navigation. The VW allows streaming of music via Bluetooth. A very nice feature. I wish the Crosstour could do that. But most of all I wish the Crosstourncould stream from apps without throwing the unsupported device error.
Our Crosstours wont steam music via BT... it requires a BT protocol that our car is not equipped with.

I'm still waiting to find out whether there is a car software/firmware upgrade that will allow for problem-free Pandora playing.
Xaque is offline   Reply With Quote
Old 10-26-2012, 09:41 AM   #8
HondaKiller
Junior Member
 
Join Date: Oct 2012
Posts: 22
Default

Any updates on the Pandora issue with the USB? I'm having the same problem and just put up a new post about it. Thanks!!
HondaKiller is offline   Reply With Quote
Old 10-27-2012, 02:28 AM   #9
SoonerMock
Junior Member
 
Join Date: Oct 2012
Posts: 17
Default

I have a 2010 EX-L without nav. I have an iPhone 4S and my wife has an iPhone 5, both running iOS 6. Pandora works fine for me. No crashes, song and artist info comes through on the screen. About half the time I can even skip songs via the button on the steering wheel. Not sure why I can't the rest of the time.

It's odd that it is working so well for me, but I keep hearing about others having issues. One thing I did figure out is that if you use iTunes Match/iTunes in the cloud you have to have at least one song stored on your device or the car will say No Content, and Music, Pandora, Audible, etc wont work.
SoonerMock is offline   Reply With Quote
Old 11-05-2012, 11:34 AM   #10
edubfromktown
Senior Member
 
edubfromktown's Avatar
 
Join Date: Jul 2010
Location: Maryland
Posts: 232
Default

I had an iPhone 4 and now have a 5. Both work fine in my 2010 CT. The only strangeness I experienced was the first time I plugged the iPhone 5 in and listened to music. After ~1 hour the CT console showed an unsupported device message... I think I received a txt message around then. After unplugging the iPhone 5 and plugging it back in, worked fine. Haven't had an issue since.
edubfromktown is offline   Reply With Quote
Old 11-05-2012, 01:09 PM   #11
HondaKiller
Junior Member
 
Join Date: Oct 2012
Posts: 22
Default Unsupported

Yup....guess I'm jealous. I get UNSUPPORTED after a few songs, and its every time I try to use it. I have an Iphone 4S with 6.0 and now 6.0.1. Both operating systems seem to crash the radio after awhile. CRAZY!

Oh well...the car is awesome so whatever.
HondaKiller is offline   Reply With Quote
Old 11-19-2012, 10:58 AM   #12
asteng88
Junior Member
 
Join Date: Nov 2012
Posts: 1
Question "No Songs"

I have an iphone 4S and on occasion i used to get the unsupported device but now since upgrading to IOS 6.0.1 I get "No Music". It all started in IOS 6.0 and the whole thing would act strangely and since the upgrade it wont pick up my music at all. Its frustrating enough that the interface is so slow on the CT but now it won't pick up any of my songs at all.

There must be a firmware or software upgrade for the CT. The interface isn't exactly state of the art so I hope they have done something.
asteng88 is offline   Reply With Quote
Old 11-20-2012, 12:54 AM   #13
SoonerMock
Junior Member
 
Join Date: Oct 2012
Posts: 17
Default

Quote:
Originally Posted by asteng88 View Post
I have an iphone 4S and on occasion i used to get the unsupported device but now since upgrading to IOS 6.0.1 I get "No Music". It all started in IOS 6.0 and the whole thing would act strangely and since the upgrade it wont pick up my music at all. Its frustrating enough that the interface is so slow on the CT but now it won't pick up any of my songs at all.

There must be a firmware or software upgrade for the CT. The interface isn't exactly state of the art so I hope they have done something.
asteng88 - I might have a solution for you. Do you happen to have an iTunes Match account?

Turns out that due to their licensing agreement with the record companies, Apple disables streaming via a USB connection when using the iTunes Match service. What this means for us is that songs that aren't stored in the device's memory (not including temp memory) can't be played from the Music app through the USB connection.

It's possible that if it was working before you upgraded, that you had songs stored on the device that were removed during the upgrade. Note that if this is the case all of your songs will still show up and play, they are just streaming from Apple's servers instead of being stored on your device.

Honda's system requires a handshake with the Music app, which is the only app that it officially supports, that tells the car that there are songs in the app, what songs/playlists/etc there are, and subsequently sends the data to the car. If the iPhone fails that test the car will tell you that you don't actually have any music.

It took me hours of research to figure out that this was the problem when it happened to me. I finally just started trying things that made sense once I learned about Apple's streaming restrictions. I confirmed that it was the issue when I tried a friend's phone with iTunes Match and they had the same issue, then my wife's and another friend's phones without Match, which both worked.

Here's how to fix it:
  1. Go to any album or playlist on your iPhone in the Music app.Scroll to the bottom.
  2. Scroll to the bottom
  3. Tap the little icon that looks like a cloud with a down arrow inside of it. This will download the songs above the button to your device.
  4. When they are done downloading (you'll know because the little rings that appeared next to the songs will complete), plug your phone back into your car via USB.
  5. Hopefully now everything works!

Another thing to note is that if you want to use Pandora or Audible or any other audio apps, you can do so by plugging your phone into the car, starting music in the music app, then switching to one of the other apps and hitting play.

I hope this helps you. I know I was very frustrated when I experienced the same thing, but now that everything is working for me I couldn't be happier with the system.
SoonerMock is offline   Reply With Quote
Old 11-28-2012, 12:49 PM   #14
Genoz
Junior Member
 
Join Date: Oct 2012
Posts: 8
Default

I have the 2012 CT, EXL without nav, Iphone 4 worked fine, Iphone 5 will not play music or pandora. The service dept has no clue. Turning off match does not work. When I plug my phone in the phone goes to Aux control, the car stereo goes to ipod no music, so I can't control from phone or stereo. I can plug in as aux and listen so it must be a USB quirk. Please let me know if you solve this problem cause Honda support is useless.
Genoz is offline   Reply With Quote
Old 11-29-2012, 07:28 PM   #15
SoonerMock
Junior Member
 
Join Date: Oct 2012
Posts: 17
Default

Quote:
Originally Posted by Genoz View Post
I have the 2012 CT, EXL without nav, Iphone 4 worked fine, Iphone 5 will not play music or pandora. The service dept has no clue. Turning off match does not work. When I plug my phone in the phone goes to Aux control, the car stereo goes to ipod no music, so I can't control from phone or stereo. I can plug in as aux and listen so it must be a USB quirk. Please let me know if you solve this problem cause Honda support is useless.
After you turned off iTunes Match, do you have any songs in your library?
SoonerMock is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 07:54 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.